s390 architecture · Supported
Maintainers
- M Heiko Carstens <hca@linux.ibm.com>
- M Vasily Gorbik <gor@linux.ibm.com>
- M Alexander Gordeev <agordeev@linux.ibm.com>
- R Christian Borntraeger <borntraeger@linux.ibm.com>
- R Sven Schnelle <svens@linux.ibm.com>
Paths
- F
Documentation/driver-api/s390-drivers.rst - F
Documentation/arch/s390/ - F
arch/s390/ - F
drivers/s390/ - F
drivers/watchdog/diag288_wdt.c
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-acpi (capped at 30), ordered by date desc.
-
COLD45d
[PATCH 09/11] treewide: Convert custom kernel_param_ops .get callbacks to seq_buf via cocci
2026-05-21 · Kees Cook <kees@kernel.org> -
COLD45d
[PATCH 04/11] treewide: Convert struct kernel_param_ops initializers to DEFINE_KERNEL_PARAM_OPS
2026-05-21 · Kees Cook <kees@kernel.org> -
STALE86d
[PATCH v3 05/14] s390/pkey: Remove redundant rcu_read_lock/unlock() in spin_lock
2025-09-16 · pengdonglin <hidden> -
STALE312d
[PATCH v2] rcu: Remove redundant rcu_read_lock/unlock() in spin_lock critical sections
2025-09-15 · pengdonglin <hidden> -
STALE289d
[PATCH RESEND 55/62] init: rename CONFIG_BLK_DEV_INITRD to CONFIG_INITRAMFS
2025-09-14 · Askar Safin <hidden> -
STALE289d
[PATCH RESEND 42/62] init: rename <linux/initrd.h> to <linux/initramfs.h>
2025-09-14 · Askar Safin <hidden> -
STALE289d
[PATCH RESEND 28/62] init: alpha, arc, arm, arm64, csky, m68k, microblaze, mips, nios2, openrisc, parisc, powerpc, s390, sh, sparc, um, x86, xtensa: rename initrd_{start,end} to virt_external_initramfs_{start,end}
2025-09-13 · Askar Safin <hidden> -
STALE289d
[PATCH RESEND 21/62] init: remove all mentions of root=/dev/ram*
2025-09-13 · Askar Safin <hidden> -
STALE289d
[PATCH RESEND 14/62] init: m68k, mips, powerpc, s390, sh: remove Root_RAM0
2025-09-13 · Askar Safin <hidden> -
STALE314d
[PATCH] rcu: Remove redundant rcu_read_lock/unlock() in spin_lock critical sections
2025-09-12 · pengdonglin <hidden> -
STALE341d
[PATCH] mm/numa: Rename memory_add_physaddr_to_nid to memory_get_phys_to_nid
2025-08-18 · <hidden> -
STALE506d
[PATCH 7/8] s390: mv s390 sysctls into their own file under arch/s390 dir
2025-02-18 · joel granados <joel.granados@kernel.org> -
STALE563d
REVIEWED: 45 (45M) [PATCH v7] mm/memblock: Add memblock_alloc_or_panic interface
2024-12-22 · Guo Weikang <hidden> -
STALE580d
[PATCH v6] mm/memblock: Add memblock_alloc_or_panic interface
2024-12-22 · Guo Weikang <hidden> -
STALE581d
[PATCH v5] mm/memblock: Add memblock_alloc_or_panic interface
2024-12-22 · Guo Weikang <hidden> -
STALE581d
[PATCH v4] mm/memblock: Add memblock_alloc_or_panic interface
2024-12-22 · Guo Weikang <hidden> -
DORMANTno replies
[PATCH v3] mm/memblock: Add memblock_alloc_or_panic interface
2024-12-21 · Guo Weikang <hidden> -
STALE581d
[PATCH v2] mm/memblock: Add memblock_alloc_or_panic interface
2024-12-21 · Guo Weikang <hidden> -
STALE581d
[PATCH] mm/memblock: Add memblock_alloc_or_panic interface
2024-12-20 · Guo Weikang <hidden> -
STALE605d
REVIEWED: 7 (5M) [PATCH v4 07/26] arch, mm: move definition of node_data to generic code
2024-08-07 · Mike Rapoport <rppt@kernel.org> -
STALE718d
REVIEWED: 6 (5M) [PATCH v3 08/26] arch, mm: move definition of node_data to generic code
2024-08-01 · Mike Rapoport <rppt@kernel.org> -
STALE729d
REVIEWED: 6 (5M) [PATCH v2 08/25] arch, mm: move definition of node_data to generic code
2024-07-23 · Mike Rapoport <rppt@kernel.org> -
STALE733d
[PATCH 04/17] arch, mm: move definition of node_data to generic code
2024-07-16 · Mike Rapoport <rppt@kernel.org> -
STALE904d
[PATCH v2 4/6] ubsan: Remove CONFIG_UBSAN_SANITIZE_ALL
2024-02-02 · Kees Cook <hidden> -
STALE1269d
[PATCH v2 4/6] mm: replace vma->vm_flags indirect modification in ksm_madvise
2023-01-25 · Suren Baghdasaryan <surenb@google.com> -
STALE1269d
[PATCH v2 3/6] mm: replace vma->vm_flags direct modifications with modifier calls
2023-01-25 · Suren Baghdasaryan <surenb@google.com> -
STALE1463d
LANDED: 8 (6M) [PATCH v6 1/4] PCI: Remove pci_get_legacy_ide_irq and asm-generic/pci.h
2022-07-22 · Stafford Horne <shorne@gmail.com> -
STALE1464d
REVIEWED: 8 (6M) [PATCH v5 1/4] PCI: Remove pci_get_legacy_ide_irq and asm-generic/pci.h
2022-07-21 · Stafford Horne <shorne@gmail.com> -
STALE1465d
REVIEWED: 3 (2M) [PATCH v4 1/3] PCI: Remove pci_get_legacy_ide_irq and asm-generic/pci.h
2022-07-20 · Stafford Horne <shorne@gmail.com> -
STALE1619d
[PATCH][next] treewide: Replace zero-length arrays with flexible-array members
2022-02-15 · "Gustavo A. R. Silva" <gustavoars@kernel.org>